summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEdgard Lima <edgard.lima@indt.org.br>2005-11-22 15:09:28 +0000
committerEdgard Lima <edgard.lima@indt.org.br>2005-11-22 15:09:28 +0000
commita5ef8aef56c1639abcc23b7ba19c00225a041e89 (patch)
treebc33c90323654be703b24750180402ae4dd35dca /configure.ac
parentee0e50b84d25f2886d41c9629c01edc376237fcd (diff)
downloadgst-plugins-bad-a5ef8aef56c1639abcc23b7ba19c00225a041e89.tar.gz
gst-plugins-bad-a5ef8aef56c1639abcc23b7ba19c00225a041e89.tar.bz2
gst-plugins-bad-a5ef8aef56c1639abcc23b7ba19c00225a041e89.zip
Musepackdec ported to 0.9. There is still a small problem to be solved, after the end of file, the pipeline doens't s...
Original commit message from CVS: Musepackdec ported to 0.9. There is still a small problem to be solved, after the end of file, the pipeline doens't stop.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8c581357..910af2e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -399,6 +399,18 @@ else
AC_SUBST(X_LIBS)
fi
+dnl *** musepack ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_MUSEPACK, true)
+GST_CHECK_FEATURE(MUSEPACK, [musepackdec], musepack, [
+ AC_LANG_CPLUSPLUS
+ AC_CHECK_HEADER([mpcdec/mpcdec.h], [
+ HAVE_MUSEPACK="yes"
+ MUSEPACK_LIBS="-lmpcdec"
+ AC_SUBST(MUSEPACK_LIBS)
+ ], [HAVE_MUSEPACK="no"])
+ AC_LANG_C
+])
+
dnl *** SDL ***
translit(dnm, m, l) AM_CONDITIONAL(USE_SDL, true)
@@ -508,6 +520,7 @@ ext/faac/Makefile
ext/faad/Makefile
ext/ivorbis/Makefile
ext/gsm/Makefile
+ext/musepack/Makefile
ext/sdl/Makefile
docs/Makefile
docs/plugins/Makefile