summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8c581357..910af2e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -399,6 +399,18 @@ else
AC_SUBST(X_LIBS)
fi
+dnl *** musepack ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_MUSEPACK, true)
+GST_CHECK_FEATURE(MUSEPACK, [musepackdec], musepack, [
+ AC_LANG_CPLUSPLUS
+ AC_CHECK_HEADER([mpcdec/mpcdec.h], [
+ HAVE_MUSEPACK="yes"
+ MUSEPACK_LIBS="-lmpcdec"
+ AC_SUBST(MUSEPACK_LIBS)
+ ], [HAVE_MUSEPACK="no"])
+ AC_LANG_C
+])
+
dnl *** SDL ***
translit(dnm, m, l) AM_CONDITIONAL(USE_SDL, true)
@@ -508,6 +520,7 @@ ext/faac/Makefile
ext/faad/Makefile
ext/ivorbis/Makefile
ext/gsm/Makefile
+ext/musepack/Makefile
ext/sdl/Makefile
docs/Makefile
docs/plugins/Makefile