summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Schaller <uraeus@gnome.org>2005-05-06 18:00:56 +0000
committerChristian Schaller <uraeus@gnome.org>2005-05-06 18:00:56 +0000
commitc566d1d5d121d95b7cdabda8f4bcaca2f5401a0f (patch)
tree5bfde4e1744181da2828cb833facabaede1b943b /configure.ac
parent4d3647265634c63bfb1f901c4c3d537e6a342816 (diff)
downloadgst-plugins-bad-c566d1d5d121d95b7cdabda8f4bcaca2f5401a0f.tar.gz
gst-plugins-bad-c566d1d5d121d95b7cdabda8f4bcaca2f5401a0f.tar.bz2
gst-plugins-bad-c566d1d5d121d95b7cdabda8f4bcaca2f5401a0f.zip
add gst-plugins-libs
Original commit message from CVS: add gst-plugins-libs
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9ce7b321..d3d97381 100644
--- a/configure.ac
+++ b/configure.ac
@@ -253,6 +253,16 @@ fi
AC_SUBST(GST_INTERFACES_LIBS)
+dnl check for gstreamer-interfaces; uinstalled is selected preferentially
+PKG_CHECK_MODULES(GST_PLUGINS_LIBS, gstreamer-libs-$GST_MAJORMINOR >= $GST_REQ,
+ HAVE_GST_PLUGINS="yes", HAVE_GST_PLUGINS="no")
+
+if test "x$HAVE_GST_PLUGINS" = "xno"; then
+ AC_MSG_ERROR(no GStreamer Plugins Libs found)
+fi
+
+AC_SUBST(GST_PLUGINS_LIBS)
+
dnl Determine endianness
AC_C_BIGENDIAN