summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorMichal Benes <michal.benes@itonis.tv>2007-03-25 13:06:26 +0000
committerTim-Philipp Müller <tim@centricular.net>2007-03-25 13:06:26 +0000
commit8d5738ab90da66e297b5611c24faae96352257dd (patch)
treef2cec796d6ec6f556af4dfbc26070ef6c7b3784e /ext/Makefile.am
parentd0b8c40cec16ecef4b270d39c3e88bf4d0d3cda3 (diff)
downloadgst-plugins-bad-8d5738ab90da66e297b5611c24faae96352257dd.tar.gz
gst-plugins-bad-8d5738ab90da66e297b5611c24faae96352257dd.tar.bz2
gst-plugins-bad-8d5738ab90da66e297b5611c24faae96352257dd.zip
Add libx264-based h264 encoder plugin (#421110). Probably doesn't handle 'odd' widths and heights correctly yet.
Original commit message from CVS: Patch by: Michal Benes <michal.benes at itonis tv> Patch by: Josef Zlomek <josef.zlomek at itonis tv> * configure.ac: * ext/Makefile.am: * ext/x264/Makefile.am: * ext/x264/gstx264enc.c: (gst_x264_enc_me_get_type), (gst_x264_enc_analyse_get_type), (gst_x264_enc_timestamp_queue_init), (gst_x264_enc_timestamp_queue_free), (gst_x264_enc_timestamp_queue_put), (gst_x264_enc_timestamp_queue_get), (gst_x264_enc_header_buf), (gst_x264_enc_set_src_caps), (gst_x264_enc_sink_set_caps), (gst_x264_enc_base_init), (gst_x264_enc_class_init), (gst_x264_enc_init), (gst_x264_enc_init_encoder), (gst_x264_enc_close_encoder), (gst_x264_enc_dispose), (gst_x264_enc_sink_event), (gst_x264_enc_chain), (gst_x264_enc_encode_frame), (gst_x264_enc_change_state), (gst_x264_enc_set_property), (gst_x264_enc_get_property), (plugin_init): * ext/x264/gstx264enc.h: Add libx264-based h264 encoder plugin (#421110). Probably doesn't handle 'odd' widths and heights correctly yet.
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index d8ddaa47..1f42647e 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -244,6 +244,12 @@ endif
TARKIN_DIR=
# endif
+if USE_X264
+X264_DIR=x264
+else
+X264_DIR=
+endif
+
# if USE_XINE
# XINE_DIR=xine
# else
@@ -298,6 +304,7 @@ SUBDIRS=\
$(THEORA_DIR) \
$(TIMIDITY_DIR) \
$(WAVPACK_DIR) \
+ $(X264_DIR) \
$(XINE_DIR) \
$(XVID_DIR)
@@ -330,4 +337,5 @@ DIST_SUBDIRS= \
theora \
timidity \
wavpack \
+ x264 \
xvid