summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorEric Jonas <jonas@mit.edu>2007-06-29 13:03:27 +0000
committerJan Schmidt <thaytan@mad.scientist.com>2007-06-29 13:03:27 +0000
commit96a1ebf963479fc4f45020226828a502a376826d (patch)
tree56c8e430ddf861b51af4ac3ef2908f7546530eae /ext/Makefile.am
parenteff1e94a2682e2fe72022656f5ba2ac708c073cd (diff)
downloadgst-plugins-bad-96a1ebf963479fc4f45020226828a502a376826d.tar.gz
gst-plugins-bad-96a1ebf963479fc4f45020226828a502a376826d.tar.bz2
gst-plugins-bad-96a1ebf963479fc4f45020226828a502a376826d.zip
Commit new dc1394src element.
Original commit message from CVS: * configure.ac: * ext/Makefile.am: * ext/dc1394/Makefile.am: * ext/dc1394/gstdc1394.c: (gst_dc1394_base_init), (gst_dc1394_class_init), (gst_dc1394_init), (gst_dc1394_src_fixate), (gst_dc1394_set_property), (gst_dc1394_get_property), (gst_dc1394_getcaps), (gst_dc1394_setcaps), (gst_dc1394_get_times), (gst_dc1394_create), (gst_dc1394_parse_caps), (gst_dc1394_change_state), (gst_dc1394_caps_set_format_vmode_caps), (gst_dc1394_set_caps_color), (gst_dc1394_set_caps_framesize), (gst_dc1394_set_caps_framesize_range), (gst_dc1394_caps_set_framerate_list), (gst_dc1394_framerate_const_to_frac), (gst_dc1394_get_all_dc1394_caps), (gst_dc1394_get_cam_caps), (gst_dc1394_framerate_frac_to_const), (gst_dc1394_open_cam_with_best_caps), (gst_dc1394_change_camera_transmission), (plugin_init): * ext/dc1394/gstdc1394.h: Commit new dc1394src element. Patch By: Eric Jonas < jonas at mit dot edu > Close: #387251
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index a986ee91..e3c2076f 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -46,6 +46,12 @@ else
CDAUDIO_DIR=
endif
+if USE_DC1394
+DC1394_DIR=dc1394
+else
+DC1394_DIR=
+endif
+
# if USE_DIRAC
# DIRAC_DIR=dirac
# else
@@ -265,6 +271,7 @@ SUBDIRS=\
$(AUDIORESAMPLE_DIR) \
$(BZ2_DIR) \
$(CDAUDIO_DIR) \
+ $(DC1394_DIR) \
$(DIRAC_DIR) \
$(DIRECTFB_DIR) \
$(DIVX_DIR) \
@@ -306,6 +313,7 @@ DIST_SUBDIRS = \
amrwb \
bz2 \
cdaudio \
+ dc1394 \
directfb \
faac \
faad \