summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorWouter Paesen <wouter@blue-gate.be>2007-02-08 15:00:00 +0000
committerStefan Kost <ensonic@users.sourceforge.net>2007-02-08 15:00:00 +0000
commitb74d9a063fe36645a86d873d0350e92861ac33a7 (patch)
tree1c70e723e6fa55fbdb46d577063f387dd9b2ac61 /ext/Makefile.am
parent1ec203993dbe255d83f1c984aa42fc5c858ecaed (diff)
downloadgst-plugins-bad-b74d9a063fe36645a86d873d0350e92861ac33a7.tar.gz
gst-plugins-bad-b74d9a063fe36645a86d873d0350e92861ac33a7.tar.bz2
gst-plugins-bad-b74d9a063fe36645a86d873d0350e92861ac33a7.zip
Add timitity midi render plugin (#403992)
Original commit message from CVS: Patch by: Wouter Paesen <wouter@blue-gate.be> * configure.ac: * ext/Makefile.am: * ext/timidity/Makefile.am: * ext/timidity/gsttimidity.c: (gst_timidity_base_init), (gst_timidity_class_init), (gst_timidity_init), (gst_timidity_set_song_options), (gst_timidity_src_convert), (gst_timidity_src_query), (gst_timidity_get_upstream_size), (gst_timidity_get_segment), (gst_timidity_get_new_segment_event), (gst_timidity_src_event), (gst_timidity_activate), (gst_timidity_activatepull), (gst_timidity_allocate_buffer), (gst_timidity_clip_buffer), (gst_timidity_fill_buffer), (gst_timidity_get_buffer), (gst_timidity_loop), (gst_timidity_change_state), (gst_timidity_typefind), (plugin_init): * ext/timidity/gsttimidity.h: Add timitity midi render plugin (#403992)
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index 4e960c8e..37b5fc19 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -178,6 +178,12 @@ else
NEON_DIR=
endif
+if USE_TIMIDITY
+TIMIDITY_DIR=timidity
+else
+TIMIDITY_DIR=
+endif
+
# if USE_POLYP
# POLYP_DIR=polyp
# else
@@ -232,7 +238,6 @@ else
THEORA_DIR =
endif
-
# if USE_TARKIN
# TARKIN_DIR=tarkin
# else
@@ -291,6 +296,7 @@ SUBDIRS=\
$(SWFDEC_DIR) \
$(TARKIN_DIR) \
$(THEORA_DIR) \
+ $(TIMIDITY_DIR)
$(WAVPACK_DIR) \
$(XINE_DIR) \
$(XVID_DIR)
@@ -321,5 +327,6 @@ DIST_SUBDIRS= \
spc \
swfdec \
theora \
+ timidity \
wavpack \
xvid