summaryrefslogtreecommitdiffstats
path: root/ext/hermes/Makefile.am
diff options
context:
space:
mode:
authorDavid I. Lehn <dlehn@users.sourceforge.net>2002-01-12 03:34:27 +0000
committerDavid I. Lehn <dlehn@users.sourceforge.net>2002-01-12 03:34:27 +0000
commit7f1aec856f11e0a92b56b11ee57cf3b9bc41a7ee (patch)
tree2cac67b730c4f76d9ae10f2aa072784559c4a2bb /ext/hermes/Makefile.am
parent0fd881fbf57a1e2a05c42c26c0fb5508a0c8d2d6 (diff)
downloadgst-plugins-bad-7f1aec856f11e0a92b56b11ee57cf3b9bc41a7ee.tar.gz
gst-plugins-bad-7f1aec856f11e0a92b56b11ee57cf3b9bc41a7ee.tar.bz2
gst-plugins-bad-7f1aec856f11e0a92b56b11ee57cf3b9bc41a7ee.zip
s/filter/plugin/ link plugins to GST_LIBS rearrange rules to a common format
Original commit message from CVS: * s/filter/plugin/ * link plugins to GST_LIBS * rearrange rules to a common format
Diffstat (limited to 'ext/hermes/Makefile.am')
-rw-r--r--ext/hermes/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/ext/hermes/Makefile.am b/ext/hermes/Makefile.am
index 40d88e8f..15e7c1e8 100644
--- a/ext/hermes/Makefile.am
+++ b/ext/hermes/Makefile.am
@@ -8,10 +8,14 @@ else
ARCHSRCS =
endif
-libgstcolorspace_la_SOURCES = gstcolorspace.c yuv2yuv.c yuv2rgb.c $(ARCHSRCS)
-libgstcolorspace_la_CFLAGS = $(GST_CFLAGS)
if USE_HERMES
-libgstcolorspace_la_LIBADD = $(HERMES_LIBS)
+PLUGIN_EXTRA_LIBS = $(HERMES_LIBS)
+else
+PLUGIN_EXTRA_LIBS =
endif
+libgstcolorspace_la_SOURCES = gstcolorspace.c yuv2yuv.c yuv2rgb.c $(ARCHSRCS)
+libgstcolorspace_la_CFLAGS = $(GST_CFLAGS)
+libgstcolorspace_la_LIBADD = $(GST_LIBS) $(PLUGIN_EXTRA_LIBS)
+
noinst_HEADERS = gstcolorspace.h yuv2rgb.h