summaryrefslogtreecommitdiffstats
path: root/ext/hermes/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/hermes/Makefile.am')
-rw-r--r--ext/hermes/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/ext/hermes/Makefile.am b/ext/hermes/Makefile.am
index 40d88e8f..15e7c1e8 100644
--- a/ext/hermes/Makefile.am
+++ b/ext/hermes/Makefile.am
@@ -8,10 +8,14 @@ else
ARCHSRCS =
endif
-libgstcolorspace_la_SOURCES = gstcolorspace.c yuv2yuv.c yuv2rgb.c $(ARCHSRCS)
-libgstcolorspace_la_CFLAGS = $(GST_CFLAGS)
if USE_HERMES
-libgstcolorspace_la_LIBADD = $(HERMES_LIBS)
+PLUGIN_EXTRA_LIBS = $(HERMES_LIBS)
+else
+PLUGIN_EXTRA_LIBS =
endif
+libgstcolorspace_la_SOURCES = gstcolorspace.c yuv2yuv.c yuv2rgb.c $(ARCHSRCS)
+libgstcolorspace_la_CFLAGS = $(GST_CFLAGS)
+libgstcolorspace_la_LIBADD = $(GST_LIBS) $(PLUGIN_EXTRA_LIBS)
+
noinst_HEADERS = gstcolorspace.h yuv2rgb.h