summaryrefslogtreecommitdiffstats
path: root/gst/aiffparse/Makefile.am
diff options
context:
space:
mode:
authorMichael Smith <msmith@xiph.org>2008-08-28 00:25:28 +0000
committerMichael Smith <msmith@xiph.org>2008-08-28 00:25:28 +0000
commita8661bc4de2ed86be02768497c9043b68f184c3a (patch)
tree110f39aac07ccc6aa1e800c0d62d213d3a698e14 /gst/aiffparse/Makefile.am
parent50a20db7ed4b04725afd49a73ea9f0c1a61194e1 (diff)
downloadgst-plugins-bad-a8661bc4de2ed86be02768497c9043b68f184c3a.tar.gz
gst-plugins-bad-a8661bc4de2ed86be02768497c9043b68f184c3a.tar.bz2
gst-plugins-bad-a8661bc4de2ed86be02768497c9043b68f184c3a.zip
Add an AIFF parsing element, heavily based on wavparse.
Original commit message from CVS: * configure.ac: * gst/aiffparse/Makefile.am: * gst/aiffparse/aiffparse.c: * gst/aiffparse/aiffparse.h: Add an AIFF parsing element, heavily based on wavparse.
Diffstat (limited to 'gst/aiffparse/Makefile.am')
-rw-r--r--gst/aiffparse/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/gst/aiffparse/Makefile.am b/gst/aiffparse/Makefile.am
new file mode 100644
index 00000000..ca3e212b
--- /dev/null
+++ b/gst/aiffparse/Makefile.am
@@ -0,0 +1,14 @@
+plugin_LTLIBRARIES = libgstaiffparse.la
+
+libgstaiffparse_la_SOURCES = aiffparse.c
+libgstaiffparse_la_CFLAGS = \
+ $(GST_BASE_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS) \
+ $(GST_CFLAGS)
+libgstaiffparse_la_LIBADD = \
+ $(GST_PLUGINS_BASE_LIBS) \
+ $(GST_BASE_LIBS) \
+ $(LIBM)
+libgstaiffparse_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = aiffparse.h