summaryrefslogtreecommitdiffstats
path: root/gst/cdxaparse/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2006-02-10 17:41:18 +0000
committerTim-Philipp Müller <tim@centricular.net>2006-02-10 17:41:18 +0000
commit1ca7ef34c29c044f65901d3a7c14a2e5389b252f (patch)
tree96459dccbd264d70662e76a6eba2e55d7d5a9d01 /gst/cdxaparse/Makefile.am
parentf6c865ba05181e8f1448886f5fa5e93ab6996e37 (diff)
downloadgst-plugins-bad-1ca7ef34c29c044f65901d3a7c14a2e5389b252f.tar.gz
gst-plugins-bad-1ca7ef34c29c044f65901d3a7c14a2e5389b252f.tar.bz2
gst-plugins-bad-1ca7ef34c29c044f65901d3a7c14a2e5389b252f.zip
Port cdxaparse, makes VCD playback work.
Original commit message from CVS: * configure.ac: * gst/cdxaparse/Makefile.am: * gst/cdxaparse/gstcdxaparse.c: * gst/cdxaparse/gstcdxaparse.h: Port cdxaparse, makes VCD playback work.
Diffstat (limited to 'gst/cdxaparse/Makefile.am')
-rw-r--r--gst/cdxaparse/Makefile.am21
1 files changed, 15 insertions, 6 deletions
diff --git a/gst/cdxaparse/Makefile.am b/gst/cdxaparse/Makefile.am
index ef9315b7..07a2d076 100644
--- a/gst/cdxaparse/Makefile.am
+++ b/gst/cdxaparse/Makefile.am
@@ -1,13 +1,22 @@
plugin_LTLIBRARIES = libgstcdxaparse.la
+# gstcdxastrip.c
+# gstcdxastrip.h
+
libgstcdxaparse_la_SOURCES = \
- gstcdxaparse.c \
- gstcdxastrip.c
+ gstcdxaparse.c
+
noinst_HEADERS = \
- gstcdxaparse.h \
- gstcdxastrip.h
+ gstcdxaparse.h
+
+libgstcdxaparse_la_CFLAGS = \
+ $(GST_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS)
+
+libgstcdxaparse_la_LIBADD = \
+ $(GST_LIBS) \
+ $(GST_PLUGINS_BASE_LIBS) \
+ -lgstriff-@GST_MAJORMINOR@
-libgstcdxaparse_la_CFLAGS = $(GST_CFLAGS)
-libgstcdxaparse_la_LIBADD =
libgstcdxaparse_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)