summaryrefslogtreecommitdiffstats
path: root/gst/cdxaparse/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/cdxaparse/Makefile.am')
-rw-r--r--gst/cdxaparse/Makefile.am21
1 files changed, 15 insertions, 6 deletions
diff --git a/gst/cdxaparse/Makefile.am b/gst/cdxaparse/Makefile.am
index ef9315b7..07a2d076 100644
--- a/gst/cdxaparse/Makefile.am
+++ b/gst/cdxaparse/Makefile.am
@@ -1,13 +1,22 @@
plugin_LTLIBRARIES = libgstcdxaparse.la
+# gstcdxastrip.c
+# gstcdxastrip.h
+
libgstcdxaparse_la_SOURCES = \
- gstcdxaparse.c \
- gstcdxastrip.c
+ gstcdxaparse.c
+
noinst_HEADERS = \
- gstcdxaparse.h \
- gstcdxastrip.h
+ gstcdxaparse.h
+
+libgstcdxaparse_la_CFLAGS = \
+ $(GST_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS)
+
+libgstcdxaparse_la_LIBADD = \
+ $(GST_LIBS) \
+ $(GST_PLUGINS_BASE_LIBS) \
+ -lgstriff-@GST_MAJORMINOR@
-libgstcdxaparse_la_CFLAGS = $(GST_CFLAGS)
-libgstcdxaparse_la_LIBADD =
libgstcdxaparse_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)