summaryrefslogtreecommitdiffstats
path: root/gst/festival/Makefile.am
diff options
context:
space:
mode:
authorDamien Lespiau <damien.lespiau@gmail.com>2008-07-04 16:06:09 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-07-04 16:06:09 +0000
commit1f25b18c45770894988fa8914e6cd905c4f81fa3 (patch)
treec4b79236648e0aaf1e2f898ee6fb2a6ab63a3097 /gst/festival/Makefile.am
parent4e2dcf4015d952f8311a019f06fc85765089886b (diff)
downloadgst-plugins-bad-1f25b18c45770894988fa8914e6cd905c4f81fa3.tar.gz
gst-plugins-bad-1f25b18c45770894988fa8914e6cd905c4f81fa3.tar.bz2
gst-plugins-bad-1f25b18c45770894988fa8914e6cd905c4f81fa3.zip
Fix built of the festival plugin with mingw32 by linking to ws2_32.dll and including winsock headers. Fixes bug #541522.
Original commit message from CVS: Patch by: Damien Lespiau <damien dot lespiau at gmail dot com> * configure.ac: * gst/festival/Makefile.am: * gst/festival/gstfestival.c: Fix built of the festival plugin with mingw32 by linking to ws2_32.dll and including winsock headers. Fixes bug #541522.
Diffstat (limited to 'gst/festival/Makefile.am')
-rw-r--r--gst/festival/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/gst/festival/Makefile.am b/gst/festival/Makefile.am
index 45994420..8200d065 100644
--- a/gst/festival/Makefile.am
+++ b/gst/festival/Makefile.am
@@ -1,11 +1,18 @@
plugin_LTLIBRARIES = libgstfestival.la
+if HAVE_WINSOCK2_H
+WINSOCK2_LIBS = -lws2_32
+else
+WINSOCK2_LIBS =
+endif
+
libgstfestival_la_SOURCES = gstfestival.c
libgstfestival_la_CFLAGS = $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
# we use net connection now... perhaps use the lib later
# libgstfestival_la_LIBADD = $(FESTIVAL_LIBS)
-libgstfestival_la_LIBADD = $(GST_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstaudio-0.10
+libgstfestival_la_LIBADD = $(GST_LIBS) $(GST_PLUGINS_BASE_LIBS) \
+ -lgstaudio-0.10 $(WINSOCK2_LIBS)
libgstfestival_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = gstfestival.h