summaryrefslogtreecommitdiffstats
path: root/gst/festival/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/festival/Makefile.am')
-rw-r--r--gst/festival/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/gst/festival/Makefile.am b/gst/festival/Makefile.am
index 45994420..8200d065 100644
--- a/gst/festival/Makefile.am
+++ b/gst/festival/Makefile.am
@@ -1,11 +1,18 @@
plugin_LTLIBRARIES = libgstfestival.la
+if HAVE_WINSOCK2_H
+WINSOCK2_LIBS = -lws2_32
+else
+WINSOCK2_LIBS =
+endif
+
libgstfestival_la_SOURCES = gstfestival.c
libgstfestival_la_CFLAGS = $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
# we use net connection now... perhaps use the lib later
# libgstfestival_la_LIBADD = $(FESTIVAL_LIBS)
-libgstfestival_la_LIBADD = $(GST_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstaudio-0.10
+libgstfestival_la_LIBADD = $(GST_LIBS) $(GST_PLUGINS_BASE_LIBS) \
+ -lgstaudio-0.10 $(WINSOCK2_LIBS)
libgstfestival_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = gstfestival.h