summaryrefslogtreecommitdiffstats
path: root/gst/qtmux/Makefile.am
diff options
context:
space:
mode:
authorThiago Sousa Santos <thiagossantos@gmail.com>2008-11-08 02:00:58 +0000
committerDavid Schleef <ds@schleef.org>2008-11-08 02:00:58 +0000
commite8d0f5e3b34d1657a0afe7af421d349faca216ee (patch)
tree06964dc59f8be5bea086a5c98a9183a002e0174d /gst/qtmux/Makefile.am
parent5e8f80a9f5d1a9528ff016f05ef62da24f2b546a (diff)
downloadgst-plugins-bad-e8d0f5e3b34d1657a0afe7af421d349faca216ee.tar.gz
gst-plugins-bad-e8d0f5e3b34d1657a0afe7af421d349faca216ee.tar.bz2
gst-plugins-bad-e8d0f5e3b34d1657a0afe7af421d349faca216ee.zip
Copy qtmux from revision 148 of the gst-qtmux repository.
Original commit message from CVS: patch by: Thiago Sousa Santos <thiagossantos@gmail.com> * configure.ac: * gst/qtmux/Makefile.am: * gst/qtmux/atoms.c: * gst/qtmux/atoms.h: * gst/qtmux/descriptors.c: * gst/qtmux/descriptors.h: * gst/qtmux/fourcc.h: * gst/qtmux/ftypcc.h: * gst/qtmux/gstqtmux.c: * gst/qtmux/gstqtmux.h: * gst/qtmux/gstqtmuxmap.c: * gst/qtmux/gstqtmuxmap.h: * gst/qtmux/properties.c: * gst/qtmux/properties.h: Copy qtmux from revision 148 of the gst-qtmux repository. Fixes #550280.
Diffstat (limited to 'gst/qtmux/Makefile.am')
-rw-r--r--gst/qtmux/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/gst/qtmux/Makefile.am b/gst/qtmux/Makefile.am
new file mode 100644
index 00000000..e93ff67b
--- /dev/null
+++ b/gst/qtmux/Makefile.am
@@ -0,0 +1,25 @@
+# plugindir is set in configure
+
+plugin_LTLIBRARIES = libgstqtmux.la
+
+# sources used to compile this plug-in
+libgstqtmux_la_SOURCES = gstqtmux.c \
+ atoms.c \
+ descriptors.c \
+ properties.c \
+ gstqtmuxmap.c
+
+# flags used to compile this plugin
+# add other _CFLAGS and _LIBS as needed
+libgstqtmux_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS)
+libgstqtmux_la_LIBADD = $(GST_LIBS) $(GST_BASE_LIBS)
+libgstqtmux_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+# headers we need but don't want installed
+noinst_HEADERS = gstqtmux.h \
+ atoms.h \
+ descriptors.h \
+ properties.h \
+ fourcc.h \
+ ftypcc.h \
+ gstqtmuxmap.h