summaryrefslogtreecommitdiffstats
path: root/gst/qtmux/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/qtmux/Makefile.am')
-rw-r--r--gst/qtmux/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/gst/qtmux/Makefile.am b/gst/qtmux/Makefile.am
new file mode 100644
index 00000000..e93ff67b
--- /dev/null
+++ b/gst/qtmux/Makefile.am
@@ -0,0 +1,25 @@
+# plugindir is set in configure
+
+plugin_LTLIBRARIES = libgstqtmux.la
+
+# sources used to compile this plug-in
+libgstqtmux_la_SOURCES = gstqtmux.c \
+ atoms.c \
+ descriptors.c \
+ properties.c \
+ gstqtmuxmap.c
+
+# flags used to compile this plugin
+# add other _CFLAGS and _LIBS as needed
+libgstqtmux_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS)
+libgstqtmux_la_LIBADD = $(GST_LIBS) $(GST_BASE_LIBS)
+libgstqtmux_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+# headers we need but don't want installed
+noinst_HEADERS = gstqtmux.h \
+ atoms.h \
+ descriptors.h \
+ properties.h \
+ fourcc.h \
+ ftypcc.h \
+ gstqtmuxmap.h