summaryrefslogtreecommitdiffstats
path: root/sys/dshowdecwrapper/Makefile.am
diff options
context:
space:
mode:
authorMichael Smith <msmith@xiph.org>2008-09-10 23:15:11 +0000
committerMichael Smith <msmith@xiph.org>2008-09-10 23:15:11 +0000
commit007478f09c8c10a24b473d6ac8eef1929ce25ca0 (patch)
tree7cd3ed7569f937c69df398d48e72eefe7a7753a2 /sys/dshowdecwrapper/Makefile.am
parent61dee512910cd2c9e407cc0679a492cc57333194 (diff)
downloadgst-plugins-bad-007478f09c8c10a24b473d6ac8eef1929ce25ca0.tar.gz
gst-plugins-bad-007478f09c8c10a24b473d6ac8eef1929ce25ca0.tar.bz2
gst-plugins-bad-007478f09c8c10a24b473d6ac8eef1929ce25ca0.zip
sys/dshowdecwrapper/: Major rewrite of dshowdecwrapper. Converts code to
Original commit message from CVS: * sys/dshowdecwrapper/Makefile.am: * sys/dshowdecwrapper/gstdshowaudiodec.c: * sys/dshowdecwrapper/gstdshowaudiodec.cpp: * sys/dshowdecwrapper/gstdshowaudiodec.h: * sys/dshowdecwrapper/gstdshowdecwrapper.c: * sys/dshowdecwrapper/gstdshowdecwrapper.cpp: * sys/dshowdecwrapper/gstdshowdecwrapper.h: * sys/dshowdecwrapper/gstdshowfakesrc.cpp: * sys/dshowdecwrapper/gstdshowfakesrc.h: * sys/dshowdecwrapper/gstdshowutil.cpp: * sys/dshowdecwrapper/gstdshowutil.h: * sys/dshowdecwrapper/gstdshowvideodec.c: * sys/dshowdecwrapper/gstdshowvideodec.cpp: * sys/dshowdecwrapper/gstdshowvideodec.h: Major rewrite of dshowdecwrapper. Converts code to C++, moves to direct use of DirectShow base classes, make a lot of code clearer, simplify, etc. Fix decode of MP3 on Vista by working around an apparent bug in the decoder.
Diffstat (limited to 'sys/dshowdecwrapper/Makefile.am')
-rw-r--r--sys/dshowdecwrapper/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/sys/dshowdecwrapper/Makefile.am b/sys/dshowdecwrapper/Makefile.am
index 7e9782bf..8b48452a 100644
--- a/sys/dshowdecwrapper/Makefile.am
+++ b/sys/dshowdecwrapper/Makefile.am
@@ -1,9 +1,14 @@
plugin_LTLIBRARIES = libgstdshowdecwrapper.la
-libgstdshowdecwrapper_la_SOURCES = gstdshowaudiodec.c gstdshowdecwrapper.c gstdshowvideodec.c
+libgstdshowdecwrapper_la_SOURCES = gstdshowaudiodec.cpp gstdshowdecwrapper.cpp \
+ gstdshowvideodec.cpp gstdshowutil.cpp \
+ gstdshowfakesrc.cpp
libgstdshowdecwrapper_la_CFLAGS = $(GST_CFLAGS) -I$(top_srcdir)/gst-libs/gst -DLIBGSTDSHOWDECWRAPPER_EXPORTS
-libgstdshowdecwrapper_la_LIBADD = $(GST_LIBS) $(top_builddir)/gst-libs/gst/dshow/libgstdshow-@GST_MAJORMINOR@.la
+libgstdshowdecwrapper_la_LIBADD = $(top_builddir)/gst-libs/gst/dshow/libgstdshow-@GST_MAJORMINOR@.la \
+ $(GST_BASE_LIBS) $(GST_LIBS)
libgstdshowdecwrapper_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-noinst_HEADERS = gstdshowaudiodec.h gstdshowdecwrapper.h gstdshowvideodec.h
+noinst_HEADERS = gstdshowaudiodec.h gstdshowvideodec.h gstdshowfakesrc.h \
+ gstdshowutil.h
+