summaryrefslogtreecommitdiffstats
path: root/sys/dshowdecwrapper/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sys/dshowdecwrapper/Makefile.am')
-rw-r--r--sys/dshowdecwrapper/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/sys/dshowdecwrapper/Makefile.am b/sys/dshowdecwrapper/Makefile.am
index 7e9782bf..8b48452a 100644
--- a/sys/dshowdecwrapper/Makefile.am
+++ b/sys/dshowdecwrapper/Makefile.am
@@ -1,9 +1,14 @@
plugin_LTLIBRARIES = libgstdshowdecwrapper.la
-libgstdshowdecwrapper_la_SOURCES = gstdshowaudiodec.c gstdshowdecwrapper.c gstdshowvideodec.c
+libgstdshowdecwrapper_la_SOURCES = gstdshowaudiodec.cpp gstdshowdecwrapper.cpp \
+ gstdshowvideodec.cpp gstdshowutil.cpp \
+ gstdshowfakesrc.cpp
libgstdshowdecwrapper_la_CFLAGS = $(GST_CFLAGS) -I$(top_srcdir)/gst-libs/gst -DLIBGSTDSHOWDECWRAPPER_EXPORTS
-libgstdshowdecwrapper_la_LIBADD = $(GST_LIBS) $(top_builddir)/gst-libs/gst/dshow/libgstdshow-@GST_MAJORMINOR@.la
+libgstdshowdecwrapper_la_LIBADD = $(top_builddir)/gst-libs/gst/dshow/libgstdshow-@GST_MAJORMINOR@.la \
+ $(GST_BASE_LIBS) $(GST_LIBS)
libgstdshowdecwrapper_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-noinst_HEADERS = gstdshowaudiodec.h gstdshowdecwrapper.h gstdshowvideodec.h
+noinst_HEADERS = gstdshowaudiodec.h gstdshowvideodec.h gstdshowfakesrc.h \
+ gstdshowutil.h
+