summaryrefslogtreecommitdiffstats
path: root/ext/gsm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/gsm/Makefile.am')
-rw-r--r--ext/gsm/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/ext/gsm/Makefile.am b/ext/gsm/Makefile.am
new file mode 100644
index 00000000..92df5f68
--- /dev/null
+++ b/ext/gsm/Makefile.am
@@ -0,0 +1,15 @@
+plugindir = $(libdir)/gst
+
+plugin_LTLIBRARIES = libgstgsm.la
+
+libgstgsm_la_SOURCES = gstgsm.c gstgsmdec.c gstgsmenc.c
+libgstgsm_la_LIBADD = $(GSM_LIBS)
+libgstgsm_la_CFLAGS = $(GST_CFLAGS)
+
+noinst_HEADERS = gstgsmenc.h gstgsmdec.h
+
+#check_PROGRAMS = test
+
+#test_CFLAGS = $(GSM_CFLAGS)
+#test_LDADD = $(GSM_LIBS) $(top_srcdir)/gst/libgst.la
+#test_SOURCES = test.c