aboutsummaryrefslogtreecommitdiffstats
path: root/src/engine/machina/Makefile.am
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2007-12-05 01:41:54 +0000
committerDavid Robillard <d@drobilla.net>2007-12-05 01:41:54 +0000
commitf6aea091cd1263fc5ac93333d60799fcb5791b19 (patch)
tree53561c89f5253bc5bb1fc4ac5e6cdbb8c6e8899c /src/engine/machina/Makefile.am
parent2ab01419f334b834710a41fd26a538df3522cf49 (diff)
downloadmachina-f6aea091cd1263fc5ac93333d60799fcb5791b19.tar.gz
machina-f6aea091cd1263fc5ac93333d60799fcb5791b19.tar.bz2
machina-f6aea091cd1263fc5ac93333d60799fcb5791b19.zip
Preliminary evolutionary stuff in machina.
Fix compilation against redlandmm (instead of old Raul RDF stuff). git-svn-id: http://svn.drobilla.net/lad/machina@949 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'src/engine/machina/Makefile.am')
-rw-r--r--src/engine/machina/Makefile.am23
1 files changed, 10 insertions, 13 deletions
diff --git a/src/engine/machina/Makefile.am b/src/engine/machina/Makefile.am
index 4a97f3e..e7c5a56 100644
--- a/src/engine/machina/Makefile.am
+++ b/src/engine/machina/Makefile.am
@@ -1,22 +1,19 @@
libmachinaincludedir = $(includedir)/machina
libmachinainclude_HEADERS = \
- types.hpp \
Action.hpp \
- Node.hpp \
- Edge.hpp \
- Machine.hpp \
- Loader.hpp \
- MidiAction.hpp \
ActionFactory.hpp \
Driver.hpp \
- LearnRequest.hpp \
+ Edge.hpp \
Engine.hpp \
- Recorder.hpp \
+ Gene.hpp \
+ JackDriver.hpp \
+ LearnRequest.hpp \
+ Loader.hpp \
+ Machine.hpp \
MachineBuilder.hpp \
+ MidiAction.hpp \
+ Node.hpp \
+ Recorder.hpp \
SMFDriver.hpp \
- JackDriver.hpp
-
-if WITH_JACK
- JackDriver.hpp
-endif
+ types.hpp