aboutsummaryrefslogtreecommitdiffstats
path: root/src/engine/machina/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/engine/machina/Makefile.am')
-rw-r--r--src/engine/machina/Makefile.am23
1 files changed, 10 insertions, 13 deletions
diff --git a/src/engine/machina/Makefile.am b/src/engine/machina/Makefile.am
index 4a97f3e..e7c5a56 100644
--- a/src/engine/machina/Makefile.am
+++ b/src/engine/machina/Makefile.am
@@ -1,22 +1,19 @@
libmachinaincludedir = $(includedir)/machina
libmachinainclude_HEADERS = \
- types.hpp \
Action.hpp \
- Node.hpp \
- Edge.hpp \
- Machine.hpp \
- Loader.hpp \
- MidiAction.hpp \
ActionFactory.hpp \
Driver.hpp \
- LearnRequest.hpp \
+ Edge.hpp \
Engine.hpp \
- Recorder.hpp \
+ Gene.hpp \
+ JackDriver.hpp \
+ LearnRequest.hpp \
+ Loader.hpp \
+ Machine.hpp \
MachineBuilder.hpp \
+ MidiAction.hpp \
+ Node.hpp \
+ Recorder.hpp \
SMFDriver.hpp \
- JackDriver.hpp
-
-if WITH_JACK
- JackDriver.hpp
-endif
+ types.hpp