summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2008-01-07 03:29:57 +0000
committerDavid Robillard <d@drobilla.net>2008-01-07 03:29:57 +0000
commit43dd122ffcdb6a0b40a56777245a870e411d439c (patch)
tree9f66d5009488a8ff668098829bd2a23b57d49322 /Makefile.am
parent966dbecf3e8dd13bd8af6de129a0af5b8dc83b8f (diff)
downloadraul-43dd122ffcdb6a0b40a56777245a870e411d439c.tar.gz
raul-43dd122ffcdb6a0b40a56777245a870e411d439c.tar.bz2
raul-43dd122ffcdb6a0b40a56777245a870e411d439c.zip
Raul 0.4.0.
FlowCanvas 0.4.0. Patchage 0.4.0. git-svn-id: http://svn.drobilla.net/lad/raul@1028 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0bab37c..33a850c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,17 @@
-SUBDIRS = raul src doc
+if HAVE_DOXYGEN
+DOC_DIR = doc
+dist-check-doxygen:
+else
+DOC_DIR =
+dist-check-doxygen:
+ @echo
+ @echo ' ******' You need doxygen installed to make dist.' ******'
+ @echo
+ @false
+endif
+
+SUBDIRS = raul src $(DOC_DIR)
+DIST_SUBDIRS = raul src tests doc
if BUILD_UNIT_TESTS
SUBDIRS += tests
@@ -7,5 +20,7 @@ endif
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = raul.pc
+dist-hook: dist-check-doxygen
+
docs:
cd doc && make docs