summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0bab37c..33a850c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,17 @@
-SUBDIRS = raul src doc
+if HAVE_DOXYGEN
+DOC_DIR = doc
+dist-check-doxygen:
+else
+DOC_DIR =
+dist-check-doxygen:
+ @echo
+ @echo ' ******' You need doxygen installed to make dist.' ******'
+ @echo
+ @false
+endif
+
+SUBDIRS = raul src $(DOC_DIR)
+DIST_SUBDIRS = raul src tests doc
if BUILD_UNIT_TESTS
SUBDIRS += tests
@@ -7,5 +20,7 @@ endif
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = raul.pc
+dist-hook: dist-check-doxygen
+
docs:
cd doc && make docs