aboutsummaryrefslogtreecommitdiffstats
path: root/doc/man/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2024-06-22 20:55:06 -0400
committerDavid Robillard <d@drobilla.net>2024-06-22 20:55:06 -0400
commitc930382e1f4a4ae674a7239bb8067c8d6e558b8d (patch)
treefd708c7a5284f6788a4a2af9dd15f6ee5be5a85f /doc/man/meson.build
parentc611d43d2eafc033c8d68cb4762ea7a242bf1365 (diff)
downloadserd-c930382e1f4a4ae674a7239bb8067c8d6e558b8d.tar.gz
serd-c930382e1f4a4ae674a7239bb8067c8d6e558b8d.tar.bz2
serd-c930382e1f4a4ae674a7239bb8067c8d6e558b8d.zip
Format CSS with prettier and update sylelint configuration
Diffstat (limited to 'doc/man/meson.build')
-rw-r--r--doc/man/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/doc/man/meson.build b/doc/man/meson.build
index 323a8c4d..0ce65d01 100644
--- a/doc/man/meson.build
+++ b/doc/man/meson.build
@@ -8,6 +8,17 @@ if get_option('lint')
if stylelint.found()
test('stylelint', stylelint, args: [mandoc_css], suite: 'data')
endif
+
+ prettier = find_program('prettier', required: get_option('tests'))
+ if prettier.found()
+ test(
+ 'prettier',
+ prettier,
+ args: ['--parser', 'css', '-c', mandoc_css],
+ suite: 'data',
+ workdir: meson.current_source_dir(),
+ )
+ endif
endif
if not get_option('tools').disabled()