aboutsummaryrefslogtreecommitdiffstats
path: root/doc/man/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/man/meson.build')
-rw-r--r--doc/man/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/doc/man/meson.build b/doc/man/meson.build
index 323a8c4d..0ce65d01 100644
--- a/doc/man/meson.build
+++ b/doc/man/meson.build
@@ -8,6 +8,17 @@ if get_option('lint')
if stylelint.found()
test('stylelint', stylelint, args: [mandoc_css], suite: 'data')
endif
+
+ prettier = find_program('prettier', required: get_option('tests'))
+ if prettier.found()
+ test(
+ 'prettier',
+ prettier,
+ args: ['--parser', 'css', '-c', mandoc_css],
+ suite: 'data',
+ workdir: meson.current_source_dir(),
+ )
+ endif
endif
if not get_option('tools').disabled()