aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-04-11 22:07:39 -0400
committerDavid Robillard <d@drobilla.net>2022-01-14 19:37:51 -0500
commite9b773bf452f0df0ea69e363bcb5899fea124b28 (patch)
tree6cec0e4c4d93e2fbb56576fc6992169bd985fd52 /meson.build
parent37b14ad8b07f7e8d647e15a05339d31f2ee4dd58 (diff)
downloadserd-e9b773bf452f0df0ea69e363bcb5899fea124b28.tar.gz
serd-e9b773bf452f0df0ea69e363bcb5899fea124b28.tar.bz2
serd-e9b773bf452f0df0ea69e363bcb5899fea124b28.zip
Add model
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 6711132e..5197f448 100644
--- a/meson.build
+++ b/meson.build
@@ -41,6 +41,7 @@ if get_option('strict')
'-Wno-format-nonliteral',
'-Wno-inline',
'-Wno-padded',
+ '-Wno-strict-overflow',
'-Wno-switch-default',
'-Wno-unsuffixed-float-constants',
'-Wno-unused-const-variable',
@@ -86,8 +87,13 @@ sources = [
'src/byte_sink.c',
'src/byte_source.c',
'src/caret.c',
+ 'src/compare.c',
+ 'src/cursor.c',
+ 'src/describe.c',
'src/env.c',
+ 'src/inserter.c',
'src/log.c',
+ 'src/model.c',
'src/n3.c',
'src/node.c',
'src/node_syntax.c',
@@ -105,6 +111,7 @@ sources = [
'src/uri.c',
'src/world.c',
'src/writer.c',
+ 'src/zix/btree.c',
'src/zix/digest.c',
'src/zix/hash.c',
]