aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 6711132e..5197f448 100644
--- a/meson.build
+++ b/meson.build
@@ -41,6 +41,7 @@ if get_option('strict')
'-Wno-format-nonliteral',
'-Wno-inline',
'-Wno-padded',
+ '-Wno-strict-overflow',
'-Wno-switch-default',
'-Wno-unsuffixed-float-constants',
'-Wno-unused-const-variable',
@@ -86,8 +87,13 @@ sources = [
'src/byte_sink.c',
'src/byte_source.c',
'src/caret.c',
+ 'src/compare.c',
+ 'src/cursor.c',
+ 'src/describe.c',
'src/env.c',
+ 'src/inserter.c',
'src/log.c',
+ 'src/model.c',
'src/n3.c',
'src/node.c',
'src/node_syntax.c',
@@ -105,6 +111,7 @@ sources = [
'src/uri.c',
'src/world.c',
'src/writer.c',
+ 'src/zix/btree.c',
'src/zix/digest.c',
'src/zix/hash.c',
]