aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-09-04 15:03:11 -0400
committerDavid Robillard <d@drobilla.net>2022-01-28 21:57:07 -0500
commit1fb84760a8230637a806e8e83410fc7fb6d446d2 (patch)
tree47ec80aef823da8d5c840cd053e4189dcabc8258 /test/meson.build
parentb3892cb6e4963e1bbeb346a8124101b7c3cf379b (diff)
downloadserd-1fb84760a8230637a806e8e83410fc7fb6d446d2.tar.gz
serd-1fb84760a8230637a806e8e83410fc7fb6d446d2.tar.bz2
serd-1fb84760a8230637a806e8e83410fc7fb6d446d2.zip
Add "contextual" output option
This is mainly for developer or power-user cases, where one wants to look at some data for investigation or debugging. In such cases, it's common for the set of prefixes to be implicitly known (because they are baked in to the application, for example), so printing them just produces a large amount of redundant noise. That said, it can also be useful programmatically, because it allows several snippets to be written independently and ultimately concatenated (with a header to define the prefixes) without redundancy.
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 37bae479..ae66ba37 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -236,6 +236,14 @@ if is_variable('serd_pipe')
env: test_env,
should_fail: true,
suite: ['tools', 'pipe', 'output'])
+
+ # Write options
+
+ test('contextual', files('test_contextual.py'),
+ args: pipe_test_script_args + files('../serd.ttl'),
+ env: test_env,
+ suite: ['tools', 'pipe', 'output'])
+
endif
# Test specifics for serd-sort