summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-07-19 09:54:58 -0400
committerDavid Robillard <d@drobilla.net>2022-07-20 10:35:29 -0400
commit4658288c09861a2c222636e7844f773fef43bab7 (patch)
tree0d67e66217469d0ed60d2da6824c94183e258f91 /meson.build
parentc0ef025450cf1b7eec85ae8058e0a9e301e7cd16 (diff)
downloadpatchage-4658288c09861a2c222636e7844f773fef43bab7.tar.gz
patchage-4658288c09861a2c222636e7844f773fef43bab7.tar.bz2
patchage-4658288c09861a2c222636e7844f773fef43bab7.zip
Adopt REUSE machine-readable licensing standard
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 08a71dc..862bc09 100644
--- a/meson.build
+++ b/meson.build
@@ -247,6 +247,17 @@ if not get_option('tests').disabled() and not meson.is_subproject()
suite: 'data',
)
endif
+
+ # Check licensing metadata
+ reuse = find_program('reuse', required: false)
+ if reuse.found()
+ test(
+ 'REUSE',
+ reuse,
+ args: ['--root', patchage_src_root, 'lint'],
+ suite: 'data',
+ )
+ endif
endif
if not meson.is_subproject()