summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 08a71dc..862bc09 100644
--- a/meson.build
+++ b/meson.build
@@ -247,6 +247,17 @@ if not get_option('tests').disabled() and not meson.is_subproject()
suite: 'data',
)
endif
+
+ # Check licensing metadata
+ reuse = find_program('reuse', required: false)
+ if reuse.found()
+ test(
+ 'REUSE',
+ reuse,
+ args: ['--root', patchage_src_root, 'lint'],
+ suite: 'data',
+ )
+ endif
endif
if not meson.is_subproject()