aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-05-28 15:10:28 -0400
committerDavid Robillard <d@drobilla.net>2021-05-28 15:10:28 -0400
commitb0dd657d6db1dba485702f74126c98d3463aee12 (patch)
treea943345e1c0915e1983b821cdfdbe33f9b10ace2 /meson.build
parent9ecda141fe54d0e515a80c20cbe681982c5797e6 (diff)
downloadpugl-b0dd657d6db1dba485702f74126c98d3463aee12.tar.gz
pugl-b0dd657d6db1dba485702f74126c98d3463aee12.tar.bz2
pugl-b0dd657d6db1dba485702f74126c98d3463aee12.zip
Fix build when tests and examples are disabled
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index f5e8f12..5dd60be 100644
--- a/meson.build
+++ b/meson.build
@@ -82,8 +82,9 @@ if get_option('strict')
language: ['c', 'objc'])
# C++ warnings
- cpp_warnings = all_cpp_warnings
if is_variable('cpp')
+ cpp_warnings = all_cpp_warnings
+
if cpp.get_id() == 'clang'
cpp_warnings += [
'-Wno-documentation', # Cairo