aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index f5e8f12..5dd60be 100644
--- a/meson.build
+++ b/meson.build
@@ -82,8 +82,9 @@ if get_option('strict')
language: ['c', 'objc'])
# C++ warnings
- cpp_warnings = all_cpp_warnings
if is_variable('cpp')
+ cpp_warnings = all_cpp_warnings
+
if cpp.get_id() == 'clang'
cpp_warnings += [
'-Wno-documentation', # Cairo