aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-04-22 15:49:13 -0400
committerDavid Robillard <d@drobilla.net>2022-04-23 21:18:33 -0400
commitc80ee9c1fccdf86b4c7c9d5a3b34ec024432e1a3 (patch)
tree7e32a603bcaf93540022ae669d7894851d263df5 /meson.build
parent1f33fca3bcf2f7f329f9ba46b2c19f785e00ec98 (diff)
downloadpugl-c80ee9c1fccdf86b4c7c9d5a3b34ec024432e1a3.tar.gz
pugl-c80ee9c1fccdf86b4c7c9d5a3b34ec024432e1a3.tar.bz2
pugl-c80ee9c1fccdf86b4c7c9d5a3b34ec024432e1a3.zip
Strengthen MSVC warnings
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index c135329..b3c88e6 100644
--- a/meson.build
+++ b/meson.build
@@ -77,16 +77,14 @@ if get_option('strict')
endif
elif cc.get_id() == 'msvc'
c_warnings += [
- '/wd4028', # formal parameter different from declaration
'/wd4061', # enumerator in switch is not explicitly handled
'/wd4191', # unsafe conversion from type to type
'/wd4514', # unreferenced inline function has been removed
'/wd4706', # assignment within conditional expression
'/wd4710', # function not inlined
'/wd4711', # function selected for automatic inline expansion
- '/wd4800', # implicit conversion from int to bool
'/wd4820', # padding added after construct
- '/wd4996', # function or variable may be unsafe
+ '/wd4996', # POSIX name for this item is deprecated
'/wd5045', # will insert Spectre mitigation for memory load
]
endif