aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-04-04 06:35:51 -0400
committerDavid Robillard <d@drobilla.net>2023-12-02 18:49:07 -0500
commit7219a81ad6cff840eb604983b3752d4f2097532a (patch)
tree5c071ae9575f05a75f17a2d8280e9e9aed6440ac /test/meson.build
parent1c7a8efa90003d21e19b47bbad185390cea5963c (diff)
downloadserd-7219a81ad6cff840eb604983b3752d4f2097532a.tar.gz
serd-7219a81ad6cff840eb604983b3752d4f2097532a.tar.bz2
serd-7219a81ad6cff840eb604983b3752d4f2097532a.zip
Add support for writing terse output with minimal newlines
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 937b9038..2ed73e63 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -34,6 +34,7 @@ ttl_metadata_file_paths = [
'extra/pretty/manifest.ttl',
'extra/qualify/manifest.ttl',
'extra/root/manifest.ttl',
+ 'extra/terse/manifest.ttl',
]
plot_scripts = files(plot_script_paths)
@@ -129,6 +130,7 @@ unit_tests = [
'statement',
'string',
'syntax',
+ 'terse_write',
'uri',
'world',
'writer',
@@ -407,6 +409,12 @@ test_suites = {
'--',
['-r', 'http://example.org/top/root/'],
],
+ 'terse': [
+ files('extra/terse/manifest.ttl'),
+ ns_serdtest + 'terse/',
+ '--',
+ '-t',
+ ],
}
# Run every test suite with serdi