aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 937b9038..2ed73e63 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -34,6 +34,7 @@ ttl_metadata_file_paths = [
'extra/pretty/manifest.ttl',
'extra/qualify/manifest.ttl',
'extra/root/manifest.ttl',
+ 'extra/terse/manifest.ttl',
]
plot_scripts = files(plot_script_paths)
@@ -129,6 +130,7 @@ unit_tests = [
'statement',
'string',
'syntax',
+ 'terse_write',
'uri',
'world',
'writer',
@@ -407,6 +409,12 @@ test_suites = {
'--',
['-r', 'http://example.org/top/root/'],
],
+ 'terse': [
+ files('extra/terse/manifest.ttl'),
+ ns_serdtest + 'terse/',
+ '--',
+ '-t',
+ ],
}
# Run every test suite with serdi