summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-10-23 13:41:40 -0400
committerDavid Robillard <d@drobilla.net>2022-10-23 14:57:45 -0400
commit5891e6fb17de98fae6764bdff929bcaa21a1b36c (patch)
tree681a45e62f375a2569e05c27559fcfae66bc4da9 /meson.build
parentd8b960be46007f9c09356e526d3c2dcff4b186a5 (diff)
downloadzix-5891e6fb17de98fae6764bdff929bcaa21a1b36c.tar.gz
zix-5891e6fb17de98fae6764bdff929bcaa21a1b36c.tar.bz2
zix-5891e6fb17de98fae6764bdff929bcaa21a1b36c.zip
Add C++ header build test
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 5f8d078..5d5eaa7 100644
--- a/meson.build
+++ b/meson.build
@@ -454,6 +454,18 @@ if not get_option('tests').disabled()
cpp = meson.get_compiler('cpp')
test(
+ 'test_headers_cpp',
+ executable(
+ 'test_headers_cpp',
+ files('test/cpp/test_headers_cpp.cpp'),
+ cpp_args: program_c_args,
+ dependencies: [zix_dep],
+ include_directories: include_dirs,
+ link_args: program_link_args,
+ ),
+ )
+
+ test(
'test_path_std',
executable(
'test_path_std',