summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-09-01 23:32:21 -0400
committerDavid Robillard <d@drobilla.net>2022-09-01 23:59:50 -0400
commit6dc5d6cd358569f1e9654e0ecd5c385fe508b23d (patch)
tree5132630479207b7065d9ca39dda6b11aebd4c5ab /meson.build
parent503cd786f074bead7a1c19d48bcde83ef6e4fb08 (diff)
downloadzix-6dc5d6cd358569f1e9654e0ecd5c385fe508b23d.tar.gz
zix-6dc5d6cd358569f1e9654e0ecd5c385fe508b23d.tar.bz2
zix-6dc5d6cd358569f1e9654e0ecd5c385fe508b23d.zip
Make glib a system dependency
This avoids warnings from some compilers, and clang-tidy.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 5680a1a..d6b6ca7 100644
--- a/meson.build
+++ b/meson.build
@@ -286,7 +286,8 @@ build_benchmarks = false
if not get_option('benchmarks').disabled()
glib_dep = dependency('glib-2.0',
required: get_option('benchmarks'),
- version: '>= 2.0.0')
+ version: '>= 2.0.0',
+ include_type: 'system')
if glib_dep.found()
build_benchmarks = true