summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-08-18 12:55:18 -0400
committerDavid Robillard <d@drobilla.net>2022-08-18 12:55:18 -0400
commit96c8578478669b05006be49c6b48adbd4170c314 (patch)
tree3853f2416a57c09b67200ba459ba822a5a59e05b /meson.build
parentc8345bd9827a100150a21b17d51bbb54805e9822 (diff)
downloadzix-96c8578478669b05006be49c6b48adbd4170c314.tar.gz
zix-96c8578478669b05006be49c6b48adbd4170c314.tar.bz2
zix-96c8578478669b05006be49c6b48adbd4170c314.zip
Add release metadata test
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 9 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 8805474..7d2ab27 100644
--- a/meson.build
+++ b/meson.build
@@ -186,7 +186,15 @@ threaded_tests = [
'sem_test',
]
-if not get_option('tests').disabled()
+if not get_option('tests').disabled() and not meson.is_subproject()
+ # Check release metadata
+ autoship = find_program('autoship', required: false)
+ if autoship.found()
+ test('autoship', autoship,
+ args: ['test', meson.current_source_dir()],
+ suite: 'data')
+ endif
+
# Check licensing metadata
reuse = find_program('reuse', required: get_option('tests'))
if reuse.found()