summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 9 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 8805474..7d2ab27 100644
--- a/meson.build
+++ b/meson.build
@@ -186,7 +186,15 @@ threaded_tests = [
'sem_test',
]
-if not get_option('tests').disabled()
+if not get_option('tests').disabled() and not meson.is_subproject()
+ # Check release metadata
+ autoship = find_program('autoship', required: false)
+ if autoship.found()
+ test('autoship', autoship,
+ args: ['test', meson.current_source_dir()],
+ suite: 'data')
+ endif
+
# Check licensing metadata
reuse = find_program('reuse', required: get_option('tests'))
if reuse.found()